Help Center

Using on Internet Explorer or Safari

If you log in to on the following browsers, you will be directed to see

  • Internet Explorer, version 9 or earlier
  • Safari, version 6 or earlier

Not all features are compatible with older versions of Internet Explorer or Safari. In order to provide the most stable experience within the browser, we redirect users to

If you would like to use the standard version of Twitter from your browser, we recommend upgrading your browser to a more recent version.

Note: If you are using Internet Explorer 10 and are being redirected to, please try disabling Compatibility View in your browser settings.

Still need help? Contact Support.